Quick Reference

Standard Module - Using Databases

Quick Reference

This quick reference is for Microsoft Access 2007 on Windows XP

Access 2007 Tabs

Certification Test Goals

Home

This module sets out essential concepts and skills relating to understanding
the concept of a database and demonstrating competence in using a
database.
Successful candidates will be able to:
Understand what a database is and how it is organized and operated.
Create a simple database and view the database content in various modes.
Create a table, define and modify fields and their properties; enter and edit
data in a table.
Sort and filter a table or form; create, modify and run queries to retrieve
specific information from a database.
Understand what a form is and create a form to enter, modify and delete
records and data in records.
Create routine reports and prepare outputs ready for distribution.

Create

External Data

Database Tools

Keyboard Shortcuts

Datasheet

General

Navigation

Open a database CTRL+O

Next field TAB

Save a database CTRL+S

Previous field SHIFT+TAB

Print a databaseCTRL+P

Previous screen PAGE UP

Delete DELETE

Next screen PAGE DOWN

Undo CTRL+Z

First record CTRL+HOME

Redo or Repeat CTRL+Y

Last record CTRL+END

Help F1

Navigation Pane

Switch between apps ALT+TAB

Editing

Design View

Cut CTRL+X

Properties ALT+TAB

Copy CTRL+C

Open object in

Paste CTRL+V

design view CTRL+ENTER
Save object CTRL+S

6.1.1
1

Working with Spreadsheets
Understanding
Databases

1.1

Key Concepts
Understand what a database is.
A collection of related data organised for fast search
and retrieval
Understand the difference between data and
information.
Information is the processed output of data.
Understand how a database is organised in
terms of tables, records and fields.
Tables - Data arranged in rows and columns
Records - A complete set of information in a table
Fields - A space allocated for an item of information,
containing the same type of information for each item
Know some of the common uses of large-scale
databases like:
Airline booking systems
Government records
Bank account records
Hospital patient details
Database Organisation
Understand that each table in a database should
contain data related to a single subject type.
If tables contain data related to a single subject type,
it is easier to search for and locate data.

1.1.1

1.1.2

1.1.3

1.1.4

1.2
1.2.1

1.2.2

1.2.3

Understand that each field in a table should contain
only one element of data.
For example, first name in one field, surname in
second field.
Understand that field content is associated with an
appropriate data type like: text, number, date/time,
yes/no.
Data Type - The characteristic of a field that
determines what type of data it can hold
The following are examples of different data types:

1.2.4

1.2.5

1.2.6

1.3

Text

Text, numbers, or both up to 255 characters

Memo

Text, numbers, or both up to 63,999 characters

Number

Numbers used in calculations

Date/Time

Date, times, or both up to 8 bytes

Currency

Currency values, prevents rounding

AutoNumber

Unique sequential numbers automatically added to field

Yes/No

True/False, On/Off

OLE Object

Documents created in other Office programs up to 1GB

Hyperlink

Hyperlink to a UNC path or URL up to 2048 characters

1.3.1

1.3.2

1.3.3

Create a field that allows the choice of a value from

Lookup Wizard another table or list

Understand that fields have associated field
properties like: field size, format, default value.
Field Properties - A set of characteristics that
control how the field is stored, entered, or displayed
Understand what a primary key is.
It uniquely identifies each record in a table
It allows faster data access
Understand what an index is. Understand how it
allows for faster data access.
It helps find and sort records faster
Relationships
Understand that the main purpose of relating
tables in a database is to minimize duplication of
data.
Minimizing duplication of data helps to ensure the
integrity of the data.
Understand that a relationship is built by
matching a unique field in one table with a field
in another table.
It is not possible to match duplicate field names;
each field has its own unique identifier.
Understand the importance of maintaining the
integrity of relationships between tables.
Integrity ensures that relationships are valid.
Integrity avoids records being accidentally
deleted or altered.
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1.4
1.4.1

1.4.2

1.4.3

1.4.4

Operation
Know that professional databases are designed
and created by database specialists.
These are designed using specialised software to
meet the organisation’s needs for present and future
use.
Know that data entry, data maintenance and
information retrieval are carried out by users.
Users will be granted access rights as needed for
basic data entry and search.
Know that a database administrator provides
access to specific data for appropriate users.
The database administrator implements security
measures to safeguard the organisation’s database.
Know that the database administrator is responsible
for recovery of a database after a crash or major
errors.
The database administrator has overall responsibility
for the maintenance and repair of an organisation's
database.

2

Using the Application

2.1

Working with Databases
Open a database application.
Click the Start button.
Select All Programs.
Click Microsoft Access 2007.
Close a database application.
Click the Office button.
Click Exit Access.
Open a database.

2.1.1

2.1.1

2.1.2

2.2
2.2.1

2.2.1

2.2.1

2.2.2

2.2.3

2.2.4

2.2.5

Common Tasks
Open a table, query, form, report.
Select the table, query, form or report in the
Navigation Pane.
Double-click on the object to open.
Save a table, query, form, report.
Ensure the table, query, form or report is open.
On the Home tab, in the Records group, click the
Save button.
Close a table, query, form, report.
Click the close ‘x’ icon on the top-right of the object
window.
Switch between view modes in a table, query,
form, report.
On the Home tab, in the Views group, click the
View arrow and click view preferred.
Delete a table, query, form, report.
Select the table, query, form, or report in the
Navigation Pane.
On the Home tab, in the Records group, click the
Delete button.
Click Yes to confirm deletion.
Navigate between records in a table, query, form.

3.2.1

3.2.2

Use the Navigation Bar in the lower left corner of
the window to go forward or backwards through the
records.
Sort records in a table, form, query output in
ascending, descending numeric, alphabetic order.
Click into the field to sort.
On the Home tab, in the Sort & Filter group, click the
Ascending or Descending buttons.

3

Tables

3.1

Records
Add records in a table.
Open the table in Datasheet View.
On the Home tab, in the Records group, click
the New button.
Enter data in fields as required.
Delete records in a table.
Select the record to delete.
On the Home tab, in the Records group, click the
Delete button.
Click Yes to confirm deletion.
Add, modify data in a record.
In table Datasheet View, click into the record.
Click into each field to add or modify the data.
Delete data in a record.
In table Datasheet View, click into the record.
Click into each field and press the Delete key.

3.2.3

3.1.1

2.1.2

2.1.3

Click the Office button.
Click Open.
Select database to open and click Open.
Close a database.
Click the Office button.
Click Close Database.
Create a new database and save to a location on a
drive.

3.1.1

3.1.2

3.1.2

3.2
3.2.1

3.2.4

3.2.5

3.2.6

Design
Create and name a table.
3.2.7

3.2.8

2.1.4

2.1.5

Click the Office button.
Click New.
A blank database is selected; create a file name and
select the location.
Click Create.
Restore, minimize the ribbon.
Double-click any tab to minimise the ribbon.
Double-click any tab again to restore the ribbon.
Use available Help functions
Click on the Help button
on the top right of the
ribbon.

Specify fields with their data types like: text,
number, date/time, yes/no.

In table Design View, click into the Data Type
column for the field.
Click on the drop-down arrow and select a Data
Type.
Apply field property settings: field size, number
format, date/time format, default value.

In table Design View, click into a field row.
In the General tab at the bottom of the window,
click into the Format field.
Click on the drop-down arrow and select a Format.
Create a validation rule for number, date/time,
currency.
In table Design View, click into a field row.
In the General tab at the bottom of the window,
click into the Validation Rule field.
Enter the validation rule.
Understand consequences of changing data types,
field properties in a table.
Data already entered into the table may be lost when
changing a field size attribute.
Set a field as a primary key.
In table Design View, click into the field to select as
the primary key.
In the Design tab, in the Tools group, click the
Primary Key button.
Index a field (with, without duplicates allowed).
In table Design View, click into the field row.
In the General tab at the bottom of the window,
click into the Indexed field.
Click on the drop-down arrow and select Yes (No
Duplicates).
Add a field to an existing table.
In table Design View, click into an empty field row.
Enter a new field name.
Select a Data Type from the drop-down list.
Change width of columns in a table.

On the Create tab, in the Tables group, click the
Table button.
On the Datasheet tab, in the Views group, click the
View arrow and click the Design View button.
When prompted, enter a name for the table and
click OK.
Select the column heading.
On the Home tab, in the Records group, click the
More arrow and select Column Width.
Enter a column width.
Click OK.

4

Retrieving Information

4.1

Main Operations
Use the search command for a specific word,
number, date in a field.

4.1.1

4.2.3

4.1.2

On the Home tab, in the Find group, click the
Find button.
Enter the word, number or date to find in the
Find What box.
Click Find Next to select the next occurrence of the
word or phrase until the value is found.
Apply a filter to a table, form.
4.2.4

On the Create tab, in the Other group, click the
Query Design button.
Select the table to add from the Show Table
window.
Click Add and then click Close.
Click and drag the fields required into the window
below.
Click into the field’s Criteria text box.
Enter the criteria.
Create a named two-table table query using
specific search criteria.
In the Create tab, in the Other group, click the Query
Design button.
Select the two tables to add from the Show Table
window.
Click Add and click Close.
Click and drag the fields required into the window
below.
Click into the field’s Criteria text box.
Enter the criteria.
Add criteria to a query using one or more of the
following operators: = (Equal), <> (Not equal to),
< (Less than),<= (Less than or equal to),
> (Greater than), >= (Greater than or equal to).

4.2.8

4.2.8

4.2.9

On the Design tab, in the Results group, click
the Run button.

5
5.1
5.1.1

5.1.2

5.1.3

4.2.5

4.1.3

4.2
4.2.1

4.2.2

Open the table or form.
On the Home tab, in the Sort & Filter group,
click the Filter button.
Click the boxes to deselect the rows to filter.
Click OK.
Remove the application of a filter from a table, form.
On the Home tab, in the Sort & Filter group, click the
Advanced button.
Click Clear All Filters.
Queries
Understand that a query is used to extract and
analyze data.
It allows users to locate data according to specific
search criteria.
Create a named single table query using specific
search criteria.

4.2.6

4.2.7

4.2.8

4.2.8

In query Design View, click into the field's Criteria
text box.
Enter the criteria using an arithmetic operator.
Add criteria to a query using one or more of the
following logical operators: AND, OR, NOT.
In query Design View, click into the field's Criteria
text box.
Enter the criteria using a logical operator.
Use a wildcard in a query, * or %,? or _.
In query Design View, click into the field's Criteria
text box.
Enter the criteria using a wildcard.
Edit a query: add, modify, remove criteria.
In query Design View, click into the field’s Criteria
text box.
Add, modify, or remove criteria as required.
Edit a query: add fields.
In query Design View, click into a blank field's
column heading.
Click on the arrow and select the field required.
Edit a query: remove fields.

5.1.4

5.1.5

5.1.6

5.1.6

In query Design View, select the column heading
of the field to delete.
Press the Delete key.

Edit a query: move fields.
In query Design View, select the column heading
of the field to move.
Drag and drop the field's column heading to the
required location.
Edit a query: hide, unhide fields.
To hide a field, in query Design View, click Show
criteria to remove checkmark.
To unhide a field, in query Design View, click Show
criteria to show checkmark.
Run a query.

Objects
Forms
Understand that a form is used to display and
maintain records.
It allows users to navigate through records and add,
delete, or modify records as needed.
Create and name a form.
Select a table or query.
On the Create tab, in the Forms group, click the
Form button.
Close the form and when prompted, confirm the
name of the form and click OK.
Use a form to insert new records.
On the Home tab, in the Records group, click the
New button.
Enter new records as required.
Use a form to delete records.
Select the record to delete.
On the Home tab, in the Records group, click the
Delete arrow.
Click Delete Record.
Use a form to add, modify, delete data in a record.
Use the Navigation Bar in the lower left corner of the
form window to navigate to the required record.
Click into the field to alter and add, modify or delete
data as required.
Add text in headers, footers in a form.

On the Design tab, in the Controls group, click the
Text Box button.
Go to the header or footer and click and drag to
create a text box.
Add text.
Modify text in headers, footers in a form.
Open the form in Design View.
Click in the text box in the header or footer.
Modify text as required.

6

Outputs

6.2
6.2.1

6.1
6.1.1

6.1.2

6.1.3

6.1.4

Reports, Data Export
Understand that a report is used to print selected
information from a table or query.
It allows users to create a printed copy of all or
selected data for greater ease of reference and
understanding.
Create and name a report based on a table, query.
Select a table or query.
In the Create tab, in the Reports group, click the
Report button.
Close the report and, when prompted, confirm name
of report and click OK.
Change arrangement of data fields and headings
within a report layout.
Open a report in Design View.
Click on a data field or heading and drag to required
location.
Present specific fields in a grouped report by sum,
minimum, maximum, average, count, at appropriate
break points.

6.2.1

6.2.2

6.1.5

6.1.5

6.1.6

Add a text box to the page footer or report footer
section of the report.
On the Design menu, in the Tools group, click the
Property Sheet button.
Click the Data tab and click into the Control Source
box.
Create a formula beginning with = that will calculate
the field.
Add text in headers, footers in a report.
On the Design tab, in the Controls group, click the
Text Box button.
Click and drag to place in the header or footer of the
report.
Add text.
Modify text in headers, footers in a report.
Open the report in Design View.
Click in the text box in the header or footer.
Modify text as required.
Export a table, query output in spreadsheet, text
(.txt, .csv), XML format to a location on a drive.

6.2.2

6.2.2

6.2.3

6.2.4

6.2.5

On the External Data tab, in the Export group, click
the relevant Application button. Select a location.
Click Export data with formatting and layout.
Click OK.

Printing
Change the orientation (portrait, landscape) of a
table, form, query output, report.

For more information, visit:
www.icdl.org

Open the table, form, query output or report.
Click the Microsoft Office Button, and then click Print
Preview.
On the Print Preview tab, in the Page Layout group,
click the Portrait or Landscape buttons.
Change paper size.
Open the table, form, query output or report.
Click the Microsoft Office Button, and then click Print
Preview.
On the Page Setup tab, in the Page Layout group,
click the Size button. Click on a size from the list
shown.
Print a page.

Open the object to print.
Click the Office button.
Click Print.
Under Print Range, click Pages and enter the
number reference in the From and To boxes.
Click OK.
Print selected record(s).
Open the record(s) to print.
Under Print Range, click Selected Record(s).
Click OK.
Print a complete table.
Open the table to print.
Under Print Range, click All.
Click OK.
Print all records using form layout, specific pages
using form layout.
Open the form to print.
Click the Office button.
Click Print.
To print all records, under Print Range, click All.
To print specific pages, under Print Range, click
Pages and enter the number reference in the From
and To boxes.
Click OK.
Print the result of a query.
Open the query to print.
Click on the Office button.
Click Print.
Click OK.
Print specific page(s) in a report, print complete
report.
Open the report to print.
Click on the Office button.
Click Print.
To print all pages, under Print Range, click All.
To print specific pages, under Print Range, click
Pages and enter the number reference in the From
and To boxes.
Click OK.
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