Quick Reference

Standard Module - Web Editing

Quick Reference

This quick reference is for Adobe Dreamweaver CS5.5 on Windows 7
Dreamweaver CS5.5 Opening Screen

Web Editing Goals
This module sets out essential concepts and skills relating to the
ability to understand key web publishing concepts and to create,
upload and maintain a static web site.

Application bar

Document window

Document toolbar

Workspace switcher

Insert panel

CSS Styles panel

CSS Rules panel
CSS Properties
panel

Tag selector

Property inspector

Files panel

Successful candidates will be able to:
Understand key web concepts and terms.
Know about the basic principles of HTML and use common HTML
mark-up tags to modify the layout of a web page.
Use a web authoring application to design and format web pages,
format text, and work with hyperlinks and tables.
Recognise and use common web image formats and create forms
in a web page.
Understand and use cascading style sheets.
Prepare web pages for publishing to a web server.

Keyboard Shortcuts
Editing

General
Open the file menu ALT+F

Open the edit menu ALT+E

New document CTRL+N

Cut CTRL+X

Open a document CTRL+O

Copy CTRL+C

Close the current document: CTRL+W

Paste CTRL+V

Navigation

Formatting

Up one screen PAGE UP

Bold CTRL+B

Down one screen PAGE DOWN

Italics CTRL+I
Underline CTRL+U

1

Web Concepts

1.1

Key Terms
Understand that the Internet supports a range of
services like:
The World Wide Web (WWW)
File transfer
Email
Instant messaging (IM)
Understand the term client/server.
In a client/server network, the server stores data
which can be requested and used by the client.
Understand the functionality and relationship
between the browser, web server.
A web server stores and delivers web documents.
A web browser displays pages sent by a web server.
Understand the terms domain, Uniform Resource
Locator (URL), hyperlink, web hosting, search engine.
Domain - Identifies ownership of a web address
Uniform Resource Locator (URL) - A website address
that is unique for every website
Hyperlink - A graphic or text with an embedded cross
reference that connects to web page, or portion of a
web page
Web hosting - A service which allocates space for
websites on computer servers
Search engine - Software designed to search for
information on the World Wide Web
Understand the use of primary protocols:
Transmission Control Protocol/Internet Protocol
(TCP/lP) - The protocol suite upon which the Internet
is based
Hypertext Transfer Protocol (HTTP) - Used to request
and transport World Wide Web pages across the
Internet
File Transfer Protocol (FTP) - Used to transfer files
from one computer to another over a TCP/IP network

1.1.1

1.1.2

1.1.2

1.1.3

1.1.4

1.2
1.2.1

1.2.2

1.2.3

1.2.4

1.2.5

Web Publishing
Identify the main advantages of having a website:
Access to a global audience
Ease of updating
Audience interactivity
Cost benefits
Understand the process of getting a website
online like:
Registering a domain - To obtain exclusive use of a
unique domain for a period of time
Choosing a web hosting service - To store and display
your website on computer servers that are connected
to the Internet
Recognize search engine optimization
techniques like:
Including relevant meta data
Including a site map and website links
Registering with a search engine
Recognize factors that impact on web page
download speed: audio, video, graphical
objects, animation content, file compression.
High quality Audio
High definition Video
Too many graphical objects on a web page
Animation Content - Too much on a web page can
decrease web page download speed
File compression - to decrease file size
Recognize appropriate audio, video,
graphical file formats to optimize web page
download speed.
Audio - MIDI, MP3
Video - Flash Video .flv files
Graphical file formats - jpeg, gif

1.3
1.3.1

1.3.2

Legal Issues
Understand the term copyright and its
implications for text, images, audio, video
available on websites.
Copyright is a legal way to protect the rights
of ownership of a website and any text, audio,
images and video it may contain.
Understand that website content is subject
to the laws of the country in which it is hosted.
Website content is subject to the laws of the
country in which it is hosted rather than the
country in which it was originally created.

2

HTML

2.1

Fundamentals of HTML
Understand the term Hypertext Markup
Language (HTML).
Hypertext Markup Language (HTML) is a tag
based notation language used to format
documents on the world wide web.
Understand the role of the W3C consortium in
developing HTML recommendations.
World Wide Web Consortium (W3C) is a
standards body that gives recommendations
for the development of open web standards,
HTML.
Understand the benefits these
recommendations offer like:
Interoperability of websites across browsers Allows the viewing of web pages across a
range of devices and browsers
Enhanced accessibility - Improves search
result rankings, reduces maintenance costs,
and increases audience reach
Consistent document type declarations - Give
web pages a consistent look

2.1.1

2.1.2

2.1.2
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3.2
3.2.1

3.2.1

3.2.1

3.2.1

3.2.2

3.2.2

3.2.2

Using HTML
Use the browser to view web page source code.
Click to open Internet Explorer.
Browse to the web page you want to view.
Click the View menu.
Click Source.
Use markup tags to structure a web page layout:
<html>, <head>, <title>, <body>.
Open a text editor and enter the following tags:
<html>
<head>
<title> This is a title</title>
</head>
<body> This is body text. </body>
</html>
Use markup tags to develop the layout of a
web page: <h1>, <h2>, <p>, <br />, <a href>,
<img />.
Open a text editor and enter the following tags:
<html>
<head>
<title> This is a title</title>
</head>
<h1>This is a heading</h1>
<h2>This is a smaller heading</h2>
<br />creates a single line break in a block of text
<p>This is a paragraph.</p>
<a href="http://www.ecdl.org">This is a link</a>
<img src="school.jpg" width="104" height="142" />
</html>

3.2.2

3.2.3

3.2.3

3.2.4

Using the Application
Open a web authoring application.
Click the Start button.
Select All Programs.
Click Adobe Dreamweaver CS5.5.
Close a web authoring application.
Click the File menu.
Click Exit.
Open web pages.
Click the File menu.
Click Open.
Select web pages(s) to open and click Open.
Close web pages.
Click the File menu.
To close the selected open page, click Close.
To close all open pages, click Close All.
Create a new web page.
Click the File menu.
Click New.
Click Blank Page.
Click HTML for page type.
Click Create.
Create a new website.
Click the Site menu.
Click New Site.
Enter site name and local site folder details.
Click Save.
Save a new web page to a location on a drive.
Click the File menu.
Click Save.
Create a file name and select the location.
Click Save as type and select HTML Documents.
Click Save.

3.4.1

3.4.2

3.4.2

3.4.3

3.4.3

3.2.5

Web Authoring
Design
Recognize planning and design techniques like:
Evaluating the needs of the target audience
Creating storyboards
Organizing the site structure
Creating a page layout template
Deciding on a navigation scheme
Recognize good practice in font selection.
Using sans serif fonts like: Arial, Courier,
Helvetica.
A sans serif font is suitable for a web page
because it can be easily viewed in both high and
low resolution.

Save a website to a location on a drive.
Click the Site menu.
Click New Site.
Enter local site folder details.
Click Save.
Create a new web page based on an available
template.
Click the File menu.
Click New.
Click Page from Template.
Select a site that contains the template.
Select a template.
Click Create.
Save a new web page based on an available
template.
Click the File menu.
Click Save.
Create a file name and select the location.
Click Save as type and select HTML Documents.
Click Save.
Add, edit a descriptive page title.

3.3
3.3.1

Click the Design button.
Select the text Untitled Document in the Title
box located on the Document toolbar.
Type in a new page title and press the Return key.
Change between source code and design view.
Click the Code button on the Document toolbar
to show the source code.
Click the Design button on the Document toolbar
to show the design view.
Enhancing Productivity
Set basic options/ preferences in the
application: default preview browser.

3.4.3

3.5
3.5.1

3.5.1

3.5.2

3.3.1

3.3.1

3.3.2

3.4
3.4.1

3.4.1

Click the Edit menu.
Click Preferences.
Select Preview in Browser in the Category box.
Click the Browsers + button to add details.
Click OK twice.
Set basic options/ preferences in the
application: default document type, encoding.
Click the Edit menu.
Click Preferences.
Select New Document in the Category box.
Click Default document and select a document
type.
Click Default encoding and select a default
encoding.
Click OK.
Set basic options/ preferences in the application:
fonts.
Click the Edit menu.
Click Preferences.
In Category, select Fonts.
Select an encoding type from the Font Settings list.
Select a font and size.
Proportional font - Used to display normal text
Fixed font - Used to display text within pre, code,
and tt tags
Code view - Used for all text that appears in the
Code view and Code inspector
Click OK.
Use available Help functions.
Click the Help menu.
Click Dreamweaver Help.
Text Input and Formatting
Insert text.
Enter text into the design work area.
Edit text.
Edit text as required.

3.5.2

3.5.3

3.5.3

3.5.3

3.5.3

3.6
3.6.1

3.6.2

Delete text.
Select the text to delete.
Press the Delete key.
1
Understand relative font size.
Makes websites more accessible and readable
Can be set relative to surrounding elements
Allows a user to change the text size in browsers
Use relative font size.
Click the Modify menu, click CSS Styles.
Double click an existing rule or property in the top
pane of the CSS Styles panel.
In the CSS Rule Definition dialog box, select
Type, and then set the style properties.
Click the Font-size drop-down arrow and choose
a relative size, for example, medium.
Click OK.
Apply text formatting: bold, italic.
Select the text to format.
To embolden the text, click the Format menu,
select Style and click Bold.
To italicize the text, click the Format menu, select
Style and click italic.
Apply text formatting: font type.
Select the text to format.
Click the Format menu.
Select Font and click on a font from the list.
Apply text formatting: color.
Select the text to color.
Click the Format menu.
Click Colour and select a color.
Click OK.
Paragraph Formatting
Set paragraph properties: alignment.
Select the paragraph to align.
Click the Format menu.
Select Align.
Select Left, Centre, Right, Justify.
Set paragraph properties: indentation.
Select the paragraph to indent.
Click the Format menu.
Click Indent or Outdent.
Insert, remove paragraph break.
To insert press the Return key.
To remove click on the paragraph break and press
the Delete key.
Insert, remove line break.
To insert position the cursor to force a line break.
Click the Insert menu.
Select HTML and select Special Characters.
Click Line Break.
To remove click at the beginning of the line break
and press the Backspace key.
Create a single-level ordered numbered list.
Select the text to list.
Click the Format menu.
Select List and click Ordered List.
Modify a single-level ordered numbered list.
Click anywhere in the list.
Click the Format menu.
Select List and click Properties.
Create an unordered bulleted list.
Click anywhere in the list.
Click the Format menu.
Select List.
Click Properties.
Modify an unordered bulleted list.
Click anywhere in the list.
Click the Format menu.
Select List.
Click Properties.
Page Formatting
Set page margins: top, bottom, left, right.
Click the Modify menu.
Click Page Properties.
Enter a left, right, top, bottom, margin.
Click Apply.
Add, modify a page background color.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).

3.6.2

3.6.2

3.6.2

3.6.3

Click the Background color box.
Select a color from the color picker.
Remove a page background color.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Click the Background color box.
Click the Default Color button on the top of the
color picker.
Add, modify a background image.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Beside Background image click the Browse button
in the Select Image Source dialog box.
Navigate to and select the image.
Click OK, click Apply and click OK.
Remove a background image.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Select the text in the Background image box.
Press the Delete key.
Click Apply and click OK.
Change a page hyperlink colour: visited,
active, unvisited.

3.7.3

3.7.3

3.7.3

3.7.4

3.7.5

Click the Modify menu.
Click Page Properties.
Click Links (CSS).
Visited - Click the Visited links color picker and
select a color.
Click the appropriate links color picker and select
a color.
3.7
3.7.1

3.7.2

Hyperlinks
Understand the terms absolute and relative
hyperlinks.
Absolute hyperlinks are used when linking to pages
outside of the current site that have a different
domain name.
Relative hyperlinks are addresses that are relative
to the current domain or location.
Insert a hyperlink: text, image.

3.7.5

Insert, an e-mail hyperlink: text, image.
Click in the web page where the link should appear.
Click the Insert menu.
Click Email Link.
In the Text box, enter text for the hyperlink.
In the Email box, enter the email address.
Click OK.
Edit an e-mail hyperlink: text, image.
Select the link.
Click the Insert menu.
Click Email Link.
In the Text box, edit text for the hyperlink.
In the Email box, edit the email address.
Click OK.
Remove an e-mail hyperlink: text, image.
Click on the hyperlink to remove.
Click the Modify menu.
Click Remove Link.
Define hyperlink target: same window, new
window.
Click the Insert menu.
Click Hyperlink.
Click in the Target arrow:
_blank - loads the linked file into a new, unnamed
browser window
_self - loads the linked file into the same frame or
window as the link
Click OK.
Set an anchor.
Click in front of the first letter of the word to be
anchored.
Click the Insert menu.
Click Named Anchor.
Click in the Anchor name box and enter a name.
Click OK.
Insert a link to an anchor.
Select the text to be linked.
Click Point to File in the Properties inspector.
Drag the arrow to the anchor to link to and
release the mouse button.

3.8.4

3.8.4

3.8.5

3.8.5

3.8.6

3.8.6

3.8.7

3.8.8

3.8.8

3.8.9
3.8
3.8.1

Tables
Insert a table.

3.8.9

3.7.2

3.7.2

Click in the web page where the link should appear.
Click the Insert menu.
Click Hyperlink.
Click in the Text box and enter the link text.
Click in the Link box and enter the name of the file
to link to.
Click in the Target box and enter or select the name
of the window in which the file should open.
Click in the Title box and enter a title for the link.
Click in the Access Key box and enter a keyboard
equivalent (one letter) to select the link in the
browser.
Click in the Tab index box and enter a number for
the tab order.
Click OK.
Edit a hyperlink: text, image.
Click on the hyperlink for editing.
Click the Modify menu.
Click Change Link.
Enter the new file or URL details.
Click OK.
Remove a hyperlink: text, image.
Click on the hyperlink to remove.
Click the Modify menu.
Click Remove Link.

3.8.1

3.8.2

3.8.2

3.8.3

3.8.4

Click in the page where the table should appear.
Click the Insert menu, click Table.
In the Table dialog enter settings as required.
Delete a table.
Select the table and press the Delete key.
Insert a table caption.
Click where you want the table to appear.
Click the Insert menu.
Click Table, in the Table dialog enter the table
settings.
Caption - Enter a title in the Caption field.
Edit a table caption.
Click in the table caption and edit the text.
Align a table: left, centre, right.
Select the table and from the Properties inspector,
click the Align box.
Select Left, Center, Right.
Insert rows.
Click in a cell below the row to insert.
Click the Modify menu and select Table.
Click Insert Row for a row to appear above the
insertion point.

Insert columns.
Click the Modify menu and select Table.
Click Insert Column for a column to appear to
the left of the insertion point.
Delete rows and columns.
Click in a cell within the row or column to delete.
Click the Modify menu and select Table.
Click Delete Row or Delete Column.
Modify column width.
Drag the right border of the column you want to
change.
Modify row height.
Drag the lower border of the row you want to
change.
Merge cells.
Select the cells in a line or a rectangle shape.
Click the Modify menu and select Table.
Click Merge Cells.
Split cells.
Click in a cell.
Click the Modify menu and select Table.
Click Split Cell.
Modify table border width, cell padding, cell
spacing.
Select the table, in the Properties inspector, click
the Border box and enter a width.
Click the CellPad box and enter a value.
Click the CellSpace box and enter a value.
Change background colour of cells, entire table.
Select the cells and from the Properties inspector,
click on the Bg box.
Select a color from the colour picker.
Change background graphic, image of cells,
entire table.
Select the cell containing the background image
and from the Properties inspector, click on the
Browse for File folder adjacent to the Src box.
Click on an image in the Select Image Source
dialog.
Click OK.
Add a table background graphic, image.
Open the CSS Styles panel.
Double-click on a table rule in the Rules pane.
Click on Background in the Category pane. This
will open the CSS Rule Definition for table in
layout.css dialog box.
Beside Background-image click the Browse
button in the Select Image Source dialog box
and navigate to and select the image.
Click OK.
Click Apply and click OK.
Remove a table background graphic, image.
Select the table.
Open the CSS Styles panel.
Double-click on a table rule in the Rules pane.
Click on Background in the Category pane. This
will open the CSS Rule Definition for table in
layout.css dialog box.
Click the Background-image box arrow and select
None.
Click OK.
Click Apply and click OK.

4

Using Objects

4.1

Graphical Objects
Add an image on a web page.
Click the Insert menu.
Click on Image.
When the Select Image Source dialog box
appears, navigate to the image you want to use.
Click OK.
Remove an image on a web page.
Click on the image.
Press the Delete key.
Set, modify attributes of an image: size, border,
alignment, alternative text.
Select the image and use the Properties inspector
to set or modify various attributes of the image.

4.1.1

4.1.1

4.1.2

Click in the W box and enter the image width.
Click in the H box and enter the image height.
Click in the Border box and enter the width.
Click the Align drop-down box and select how the
text will wrap around the image.
Click in the Alt box and enter the image description.
4.2
4.2.1

4.2.2

4.2.2

4.2.3

4.2.3

4.2.4

4.2.4

4.2.4

4.2.4

4.2.5

4.2.5

Forms
Insert a form on a web page.
Click on the web page where the form appears.
Click the Insert menu and select Form.
Click Form and use the Properties inspector to set
various properties.
Click in the Form ID box and enter a unique name
for the form.
Click in the Action box and enter name and
location.
Click on the Method box arrow to select the method
to transmit the form data to the server.
Add single-line, multi-line text fields.
Click the Insert menu and select Form.
To add a single-line field click Text Field.
To add multi-line field click Text area.
Remove single-line, multi-line text fields.
Select the fields and press the Delete key.
Add form fields: drop-down, check box,
radio button.
Click the Insert menu and select Form.
To add a drop-down field click Select (List/Menu).
To add a check box field click Checkbox.
To add a radio button field click Radio Button.
Remove form fields: drop-down, check box,
radio button.
Select the fields and press the Delete key.
Set, modify form field properties: text field.
Click on the text field and set, modify properties
in the Properties inspector.
Char width - Enter the maximum number of
characters that can be displayed in the field
Max Chars - Enter the maximum number of
characters that can be entered in a text field
Num Lines - Enter the height of the field for a
multi-line text field
Type - Select single line or multi line
Init val - Enter default text or value
Set, modify form field properties: drop-down.
Click on the drop-down and set, modify properties
in the Properties inspector.
Select - Enter a unique name
Type - Select Menu to display a drop-down menu,
select List to display a scrollable list
Height - Enter the number of items displayed in List
Selections - Select Allow multiple to allow more than
one item to be selected from a menu
List Values - Click List Values to add, remove or
reorder items in the menu
Set, modify form field properties: check box.
Click on the check box and set, modify properties
in the Properties inspector.
Initial state - Select to have checked or unchecked
Set, modify form field properties: radio button.
Click on the radio button and set, modify properties
in the Properties inspector.
Checked Value - Enter the value to be sent to server
when radio button is selected
Initial State - Select to have radio button, selected
or not selected when initially displayed in a browser
Add submit button.
Click the Insert menu and select Form.
Click Button.
Add reset button.
Click the Insert menu and select Form.
Click Button.
Select the button in the form and click Reset
form as the action in the Properties pane.

4.2.5

4.2.6

4.2.7

Remove submit, reset buttons.
Select the button and press the Delete Key.
Set, modify properties for submit, reset buttons.
Click on the button and set, modify properties in the
Properties inspector.
Value - Enter the text to appear on the button
Action - Select Submit form to submit the form data
or select Reset form to clear the form contents
Set, modify form action to send form output by
email.
Click on the web page where you want the form to
appear.
Click the Insert menu and select Form.
Click Form and use the Properties inspector to set,
modify various properties.
Action - Enter the text mailto:emailaddress
Method - Select POST
Enctype - Enter the text, text/plain

5

Styles

5.1

CSS Concepts
Understand the term Cascading Style Sheets
(CSS), their use and benefits.
A CSS page layout uses the Cascading Style Sheets
format to organise the content on a web page.
The benefits are: easier to edit, load faster, smaller in
size, quick to develop, greater control of design.
Recognize the main approaches to applying
styles:
Inline
Internal
External
Understand the structure of a CSS rule:
selector and declaration (property, value).
Declaration - it has two parts, property and value
Selector - Specifies which items in the web page
will be affected by the declaration
Selector {property:value}
H2 {color:yellow}

5.1.1

5.1.2

5.1.3

5.2
5.2.1

5.2.2

5.2.2

5.2.2

Using CSS
Create, save a new CSS file.
Click the File menu and select New.
Click Blank Page in the New Document dialog.
Page Type - click CSS.
Click the Create button.
Create a file name and select the location.
Click Save as type and select Style Sheet File.
Click Save.
Create CSS rules: font.
Open the CSS Styles panel.
Click New CSS Rule.
In the New CSS Rule dialog box, select a
selector type, selector name, and rule definition.
Click OK.
In the CSS Rule Definition dialog box, select
Type and then set the style properties for fonts.
Click Apply.
Click OK.
Create CSS rules: background.
Open the CSS Styles panel.
Click New CSS Rule.
In the New CSS Rule dialog box, select a selector
type, selector name, and rule definition.
Click OK.
In the CSS Rule Definition dialog box, select
Background and set style properties for background.
Click Apply.
Click OK.
Modify CSS rules: font.
Open the CSS Styles panel.
Click the All button on the CSS Styles panel.
Double click the rule you want to modify.
In the CSS Rule Definition dialog box, select
Type and then modify the style properties for fonts.
Click Apply.
Click OK.

5.2.2

5.2.3

Modify CSS rules: background.
Open the CSS Styles panel.
Click the All button.
Double click the rule you want to modify.
In the CSS Rule Definition dialog box, select
Background and then modify the style properties
for background.
Click Apply.
Click OK.
Attach an external CSS to a web page.
Open the CSS Styles panel.
Click the Attach Style Sheet button.
In the Attach External Style Sheet dialog box,
click Browse to browse to a CSS style sheet.
Click OK.
Select Link to create a link between the current
document and an external style sheet.
Select a media for the style sheet.
Click Preview to view styles applied.
Click OK.

6

Prepare Upload

6.1

Check
Identify and fix broken links in a website.
Click the File menu and select Check Page.
Click Links.
Any broken links found will be displayed in the
results panel under the Link Checker tab.
Recognize good practice in web page content:
Including a last updated date
Details of software required to open, view files
Ensuring web browsers compatibility
Spell check a web page and make changes.
Click the File menu and select Check Page.
Click Spelling.

6.1.1

6.1.2

6.1.3

6.2
6.2.1

6.2.1

6.2.2

6.2.2

Publish
Understand the process of uploading, a
website to a web server.
Obtain a web hosting account.
Enter details about the web hosting account.
Create the web pages for upload to the website.
Define the upload method to be used, usually FTP.
Upload the web page files to the web server.
Test the website by using a web browser.
Understand the process of downloading a
website from a web server.
Create a local folder to contain the website files.
Set up an FTP connection.
Select and download files from the web server.
Upload a website to a server.
To create a local folder click the Site menu.
Click New Site.
Click in the Site Name box and enter the name of
the website.
Click in the Local Site Folder box and enter the
location to save web pages.
Click Save.
After creating your web pages define the website.
To set up a remote folder click the Site menu.
Click Manage Site, Edit, Servers.
Click the Add New Server + button.
Click Basic at the top of the dialog box.
Enter the Server name and FTP settings.
Click Save.
Click the Site menu, click Put and click Yes.
The files will begin uploading.
Download a website from a server.
Create a local folder to contain the existing site
and set up the folder as the local folder for the site.
Set up a remote folder, using the remote access
information about the existing site.
In the Files panel, click the Connects to Remote
Host button for FTP access.
To download the full website select root folder
and click Get Files.
To download only part of the website, select files
for download and click Get Files.
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